Back to overview
Degraded

Secure Portal - Degraded Network Performance / Intermittent Timeouts

Mar 03 at 11:22am EST
Affected services
secure.shiftlinkapp.com

Resolved
Mar 03 at 01:45pm EST

Azure has mitigated the network connectivity issue impacting resources in the Canada Central region. The root cause was identified as an unhealthy network device, which has since been bypassed. Normal service has been restored, and we will continue to monitor for any lingering issues. If you continue to experience connectivity problems, please reach out to our support team.

Network connectivity issues to resources through Canada – Mitigated
Tracking ID: ZT0X-9B8
What happened?

Between 16:22 and 18:39 UTC on 03 Mar 2025, a subset of customers may have experienced issues with connectivity to Azure resources (including but not limited to Virtual Machines, App Services, SQL Database, Azure Portal) through network routes incoming and outgoing through our Canada Central region.

What do we know so far?

We identified an issue with an unhealthy network device. We have automated systems to shift traffic to help avoid impact, however a portion of network traffic was being dropped.

How did we respond?

16:22 UTC on 03 Mar 2025 – Customer impact began and customer reports were opened for investigation.
17:46 UTC on 03 Mar 2025 – Additional engineering teams were engaged.
18:39 UTC on 03 Mar 2025 – Engineering teams identified the unhealthy network device and took steps to shift traffic to healthy routes. The mitigation was completed and the engineering team is now working to ensure that the recovery is fully complete.
What happens next?

Our team will be completing an internal retrospective to understand the incident in more detail. We will publish a Preliminary Post Incident Review (PIR) within approximately 72 hours, to share more details on what happened and how we responded. After our internal retrospective is completed, generally within 14 days, we will publish a Final Post Incident Review with any additional details and learnings.
To get notified when that happens, and/or to stay informed about future Azure service issues, make sure that you configure and maintain Azure Service Health alerts – these can trigger emails, SMS, push notifications, webhooks, and more: https://aka.ms/ash-alerts
For more information on Post Incident Reviews, refer to https://aka.ms/AzurePIRs
The impact times above represent the full incident duration, so are not specific to any individual customer. Actual impact to service availability may vary between customers and resources – for guidance on implementing monitoring to understand granular impact: https://aka.ms/AzPIR/Monitoring
Finally, for broader guidance on preparing for cloud incidents, refer to https://aka.ms/incidentreadiness

Updated
Mar 03 at 12:30pm EST

We continue to investigate reports of intermittent connectivity issues affecting our platform, specifically for customers relying on Azure resources in the Canada Central region. Azure engineering teams have been engaged and are actively working to identify the root cause. We will provide further updates as soon as more information becomes available.

Created
Mar 03 at 11:22am EST

We are aware of an issue affecting connectivity to Azure-hosted resources in the Canada Central region. Customers may experience intermittent access issues with our platform due to an ongoing Azure networking incident. We are monitoring the situation closely and will provide updates as we learn more.