Incident: Webflow Hosting Provider Outage
Resolved
Aug 21 at 03:54pm EDT
Resolved - Our third-party provider has implemented a fix, and impacted services should now be working as expected. If your site was published during the incident, we recommend republishing it at this time to ensure everything updates correctly.
Aug 21, 19:54 UTC
Affected services
Created
Aug 21 at 02:21pm EDT
Monitoring – Our hosting provider Webflow is currently experiencing issues due to a widespread incident with one of their third-party service providers. This may cause intermittent problems accessing or loading our ShiftLink marketing website.
Their engineering team is actively working with the provider on a fix.
We are monitoring the situation closely and will provide updates as they become available.
Start time: Aug 21, 2025 – 18:21 UTC
Current status: Monitoring
Affected services