Cloudflare Global Network experiencing issues
Resolved
Nov 18 at 09:42am EST
Cloudflare Monitoring - A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Nov 18, 2025 - 14:42 UTC
Affected services
Updated
Nov 18 at 09:34am EST
Cloudflare Update - We've deployed a change which has restored dashboard services. We are still working to remediate broad application services impact
Nov 18, 2025 - 14:34 UTC
Affected services
Updated
Nov 18 at 08:35am EST
Cloudflare - Update - We are continuing working on restoring service for application services customers.
Nov 18, 2025 - 13:35 UTC
Affected services
Updated
Nov 18 at 08:13am EST
Cloudflare - Update - We have made changes that have allowed Cloudflare Access and WARP to recover. Error levels for Access and WARP users have returned to pre-incident rates.
We have re-enabled WARP access in London.
We are continuing to work towards restoring other services.
Nov 18, 2025 - 13:13 UTC
Affected services
Updated
Nov 18 at 08:09am EST
Cloudflare - Identified - The issue has been identified and a fix is being implemented.
Nov 18, 2025 - 13:09 UTC
Affected services
Updated
Nov 18 at 07:53am EST
Cloudflare Update - We are continuing to investigate this issue.
Affected services
Updated
Nov 18 at 07:37am EST
Cloudflare Update - We are continuing to investigate this issue.
Affected services
Updated
Nov 18 at 07:21am EST
Cloudflare Update - We are seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts.
Nov 18, 2025 - 12:21 UTC
Affected services
Updated
Nov 18 at 07:15am EST
⚠️ Cloudflare Global Network Incident — Service Intermittent
Cloudflare is currently investigating and working to resolve a global network issue affecting multiple customers. As a result, uptime for the ShiftLink Secure Web Portal and Mobile App is intermittent at this time.
We are actively monitoring the situation and will provide updates as Cloudflare progresses with their investigation and mitigation efforts.
Thank you for your patience.
Affected services
Updated
Nov 18 at 07:03am EST
Cloudflare Global Network experiencing issues
Update - We are continuing to investigate this issue.
Nov 18, 2025 - 12:03 UTC
Affected services
Created
Nov 18 at 06:48am EST
Investigating - Cloudflare is aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing.
We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Nov 18, 2025 - 11:48 UTC
Affected services